Klue App Performance Degradation

Incident Report for Klue

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 22:27 UTC

Update

System availability has been restored. We'll continue to monitor performance.
Posted Aug 20, 2025 - 17:11 UTC

Monitoring

We've implemented a fix and are monitoring to confirm a successful resolution.
Posted Aug 20, 2025 - 17:00 UTC

Identified

We have identified an issue that is causing degraded performance with app.klue.com and users may experience timeouts, slow loading and issues with integrations. We have identified the cause and are working on implementing a fix.
Posted Aug 20, 2025 - 16:40 UTC
This incident affected: app.klue.com.