Klue App Performance Degredation
Incident Report for Klue
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 19:14 UTC
Monitoring
We have implemented a fix and are actively monitoring the performance of the application.
Posted Jul 27, 2023 - 16:33 UTC
Investigating
We are currently investigating an app-wide issue that is causing degraded performance in the Klue app. Users may experience timeouts, slow loading and issues with integrations.

Our team is working to identify the root cause of the issue and will fix it as soon as possible.
Posted Jul 27, 2023 - 15:41 UTC
This incident affected: app.klue.com.