Impact from AWS Downtime

Incident Report for Klue

Resolved

All services have returned to normal operations following the resolution of the AWS us-east-1 outage. app.klue.com is fully accessible and performing as expected. Delayed scheduled tasks, including automated card updates and email digests, are now processing. Thank you for your patience during this incident.
Posted Oct 21, 2025 - 00:00 UTC

Monitoring

We've seen a marked improvement in our overall error rate, and performance is stabilizing. We'll continue to monitor the situation, but the trend is positive. Certain forms of scheduled tasks like automated card updates and email digests may be delayed while we recover.
Posted Oct 20, 2025 - 19:46 UTC

Update

Access to app.klue.com has degraded further due to issues with our upstream providers. We're continuing to monitor the underlying incident.
Posted Oct 20, 2025 - 16:47 UTC

Identified

We're experiencing a partial outage as a result of AWS us-east-1's outage. You may experience issues accessing app.klue.com. We're closely monitoring the recovery of the underlying incident.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 15:03 UTC
This incident affected: app.klue.com.